Can't boot into Haiku alpha 1

I was totally excited with this os and I had a spare laptop ready to be wiped off.
So I created a partition using GParted, gave it the whole hard disk and didn’t specified any file system
Then I installed Haiku following the instructions carefully.
The problem is that at the first boot the bios doesn’t even see/find the boot loader. It just shows a blank black screen with the message “no bootable device found - insert a boot cd and press any key” or something like that…
I tried to run Haiku from the live cd and it works and it’s so gorgeous that it piss me off it doesn’t boot from the hard disk.
BTW my specs are the following:

Packard Bell EasyNote V7900
CPU: Intel Centrino Duo T2300
Ram: 1024
Ati mobility radeon X1600

Is there any workaround for my issue? Is it a common one?

Yes, this seems to be a common issue, unfortunately. Your computer probably can’t find where your OS is located.

First test if the install on your hard drive works correctly:
Start up the HDD install of Haiku by booting it from the CD, following the guide:
The section which describes this procedure is called ‘Boot using the CD’ and is located towards the end. You have to be quick pressing the space bar.

After you have done this successfully, try to install the Haiku boot loader (it is not installed by default to avoid taking risks with multiboot systems):

  • Start Terminal from the application menu
  • Type bootman and press enter
  • Follow the prompts and press next until done. You should see the partion(s) on your drive listed during the process, make sure to have the Haiku partition selected.
  • Reboot and enjoy! (hopefully)

thanks for the advice.
I followed your instruction and installed the boot loader to the haiku partition.
Unfortunately after rebooting I have the same problem, the computer can’t find the boot loader.
Any idea?

Thanks again

you’re talking about gparted. Are you using linux and grub? If so, they in /boot/grub/menu.lst add this entry:

title Haiku
root (hd0,X)
chainloader +1

where X = your partition number minus 1 (counting from 0), for example if it’s /dev/sda4 then X=3)

I used the live cd of GParted. I used to run Ubuntu on that laptop but wiped all off to try Haiku

Well, then I’m not quite sure what could be your issue.

Perhaps some incompatibility between GParted, your computer/HDD and Haiku?

It might be a long shot, but you could try to install all over again and this time initialize the whole disk by creating a new intel partition map (basically wiping it) using the DriveSetup application from within the Haiku installer. And then still in DriveSetup create a new Be file system which you install to.

You do this by first starting DriveSetup as described in the installation guide. Now, click on the top entry that is listed, is says something like master/raw at the end of the device name. Make sure to select the whole drive, not just a partition. In the menu click Partition, select Initialize… and Intel partition map. Note: This will wipe all data on the disk. After you have done this you can create a partition (or several partitions) by using Partition --> Create… You then select Be file system, you can also check the ‘Active Partition’ although it shouldn’t matter if you use bootman later. Then quit DriveSetup and proceed with install as usual.

I don’t know if this will make a difference for you. I haven’t tried the procedure myself, so I can’t say if there are any bugs or shortcomings in it.

Another thing to try could of course be, as farvardin suggests, to use Grub and chainload the Haiku partition. You could install a small Linux distro like Puppy Linux just to get Grub on the drive.

to test is grub is able to run haiku or if there is another problem, you can start a linux live cd (the gparted one may work), and when it starts, hit “e” to edit temporary the boot parameters, then you can hit e again to edit a line, enter the parameter I told above (root (hd0,X) then new line and chainloader +1) then b to boot with those new parameters. Look at this for further help.

In case it’s working, install a mini linux distro to get a permanent grub boot.

Ok, I tried the method suggested by psycho_killer and I can confirm that it doesn’t work for my system.
As soon as I get some more spare time I’ll try to install a linux distro and add haiku to the grub menu.
I did try to install ubuntu before hoping that it suggest me to install it along with the other os (haiku) but ubuntu also can’t see haiku (probably for the same reason the bios doesn’t).
Thanks again

I performed the method suggested by farvardin but it does’t work.
I tried different combinations of filesystems, reinstalled haiku all the time but grub doesn’t seem able to see haiku even if I set menu.lst correctly as suggested by farvardin and by the tip before the installation gui.
I don’t really know what to try now.
I suppose I must wait for the next release of haiku to see if the improvements you guys are working on will enable me to run the os.
I’m a bit disillusioned but at least I learnt how much the booting process is delicate. I didn’t realise this before this experience.
Thanks a lot and good work with this wonderful project.

well, it’s a pity it doesn’t work for you :frowning:

I could only suggest to d/l a raw image, and copy/transfer it to an usb key, so you may be able to boot on this one (even if I doubt it would work better).

Maybe you have no bootloader in the MBR? Anyway I have never installed Haiku off the LiveCD onto a blank hdd but I will tell you how I installed it on two other computers. The first computer was previously running XP. I shrunk the size of the XP partition using GParted, created a FAT32 partition in the free space, booted up using the PCLinuxOS LiveCD, and “dd”'d one of the raw images to the new partition. This was before Alpha 1 came out. Then I booted back into XP and used the program “bootpart” to add Haiku to the NT boot menu.

The second time I had a laptop that was dual-booting Fedora and XP, and the XP installation was broken. Because of the dual-boot this system has Grub on it. I used the LiveCD and went into DriveSetup and just blasted away the XP partition and turned it into BFS. Then installed to the partition and told the installer to write the bootloader. When I rebooted grub came up again and tried to start the XP partition as it was set to do by default, only now it was Haiku, and Haiku booted.

Anyway some things to try. I am confident that if the liveCD boots you can get it running on the hdd. And it is totally worth it.

I think your problem may be due to missing boot code in the MBR, as Haiku doesn’t support installing it. When playing with qemu, I used a NetBSD install CD to put boot code in the MBR. With NetBSD there is an fdisk option -b for that.

Perhaps you can install Haiku without a Partition table, if you’re not planning to use the machine for anything else. In that case you would remove any partitions and then format the entire disk with BeFS instead of just an partition, and the Haiku boot sector installer should then be the first thing loaded by your machine’s BIOS.

I’m no expert, so take my suggestions with a grain of salt.

I also suppose the problem is totally related to the master boot record. I’ll go on trying different things to install Haiku while I wait for the next release :stuck_out_tongue: After all unless I damage the hardware I’m pretty free to experiment on that laptop and I’d like to exploit the simplicity and elegance of Haiku as the OS for my portable computer.
Anyway, out of curiosity, can someone explain me why is so difficult to manage the MBR so that the OS loads properly on any-computer? Is just a matter of maturity of Haiku development or are there more os related reasons? Really, I’m no expert in the bios or boot field and I’d like to know.
Thank you all

I had the exact same problem today, and was eventually able to solve it.

I got Haiku Alpha 1 to boot by running the GParted live CD again and setting the “boot” flag on the partition on which I installed Haiku.

Gory Details:
I used the GParted live CD to clear the drive and create 2 primary partitions (unformatted). Formatted the first to BeFS with the Haiku installer & installed Haiku Alpha 1 on it. Upon reboot, the BIOS informed me the boot sector was invalid. I booted into Haiku using the liveCD and ran makebootable and bootman. Upon reboot, I got the same error. There appears to be a difference in implementation between GParted’s ‘boot’ flag and makebootable in Haiku. I have no idea what or why… perhaps someone can explain?

Take care!

[quote=psycho_killer]… After you have done this successfully, try to install the Haiku boot loader (it is not installed by default to avoid taking risks with multiboot systems):

  • Start Terminal from the application menu
  • Type bootman and press enter
  • Follow the prompts and press next until done. You should see the partion(s) on your drive listed during the process, make sure to have the Haiku partition selected.
  • Reboot and enjoy! (hopefully)…[/quote]

I had this problem and I couldn’t boot my haiku, your instructions was the solution! :slight_smile:
Thanks for your help!