Can't boot Haiku (The colored bootsymbols never appear on my screen)


I described this Problem already in the Ticket #3441, but it seems that the reason for this problem is not known.
So I want to know if some one here has the same problem.

Ticket #3441:


I can’t boot Haiku but I think I don’t do anything wrong during the Haiku installation.

How I tried to install Haiku:

  1. flashnul (How To )
  2. From a beos based system. Copy to a Partition, makebootable and integrate in Bootman
  3. Using Virtualbox and Haiku. I configured virtualbox to have direct access to a physical HDD (Look in the VirtualBox manual at point 9.10). Use “Installer”, makbootable.

I tried 1 and 3 on an Intel Laptop and Haiku did boot on this machine. But on my machine the zbeos never appears. I only have a black screen with a blinking small white line in the top left corner.

My Hardware:
CPU: AMD Phenom X4 9550
Mainboard: MSI K9A2 Platinum (NB:790FX; SB:SB600)
GPU: Radeon X1950 Pro (RV570)

But I have the same Problem on an old PIII 800 with fujitsu-siemens server mainboard 440BX (On this machine I tried only installation methode 2)

This guy has the same mainboard an the same problem

Today I tried the “haiku-alpha-candidate-r32746-x86gcc2hybrid-iso” and tried to boot haiku from CD with the same result I described above.
Oh, not exactly the same result. At first some white dots appear on the screen an then the blinking small white line is a little bit more right.


i have a similar problem. The colored icons appear correctly but the following error message is displayed on the screen:

PANIC: CDB has invalid direction mask
Welcome to Kernel Debugging Land…
Thread 75 “eject” running on CPU 0

Then the system is halted on a prompt “kdebug>”.

My Hardware:
Lenovo Notebook T500
CPU: Intel Core2Duo P8700 @ 2,53 GHz
GPU: ATI Mobility Radeon HD 3650
RAM: 4,00 GB
HDD: Western Digital WD3200BEVS-08VAT2 with 320,00 GB
Controller: Intel ICH9M-E/M SATA AHCI Controller



sorry, i had fogotten zu mention the problem appears if i boot from the cd “haiku-alpha-candidate-r32729-x86gcc2hybrid-iso” or “haiku-alpha-candidate-r32770-x86gcc2hybrid-iso”.


After the kdl when “kdebug>” comes up, enter “sc” and then push enter on your keyboard, this should read out why haiku crashed while booting.

Hello Richie,

if have done what you said. But the complete error message type in with keyboard, is a little bit crazy. You can see the complete error message in the following “screen-shot”:

I hope that helps.



i have also tested the cd “haiku-alpha-candidate-r32770-x86gcc2hybrid-iso” on an DELL Latitude D600 and the result is also not good.
The cd starts up and the bootscreen shows right. The cd-drive makes a lot of noise and after about 6-8 minutes there is silence. The bootscreen is showing but no error message ist displayed and no desktop is coming up.


Hi René.
Please, create new ticket on and not write on forum - it doesn’t help.

Hello Hubert,

now i’m registered on but i can’t write new tickets. If i click on the “new ticket” button, a error message is displayed:

TICKET_CREATE privileges are required to perform this operation

What can i do ???


This happens to a lot of people.

[quote=richienyhus]This happens to a lot of people.


I have added this to the Development FAQ:

Hello Richie,

the verification email i have successfully done, but the verification code was not exactly correct. I have tried again and now it works.


[quote=koki][quote=richienyhus]This happens to a lot of people.


I have added this to the Development FAQ:

Maybe there could be a more prominent warning on the wiki (or via other means) temporary at the time that alpha 1 is released ?

Maybe something like the info box from the user guide ?
(even if I don’t think that can be imported to the wiki itself)

This could potentially decrease the workload for you guys at that important time. :slight_smile:

This is a good idea. Perhaps you could submit an enhancement request to Trac, so that Niels takes notice and implements it.