Can't boot Haiku (no icons light up)

I’m trying to run Haiku on a Dell XPS 15 7590 laptop, but it only gets to the logo screen before freezing with no icons lit up (at which point all the USB ports lose data connection but not power, and the fans go to max speed). I’ve tried beta 3, beta 4 RC1, and some random nightlies, various different safe mode options (although maybe not the right ones), booting from both USB and the internal SSD (by copying files from the installation media to their own partition and adding a boot sequence entry for the EFI file), and per some similar issues in this forum, booting from the USB stick with it first in the boot sequence as well as from internal disk with no USB devices attached, as well as just waiting for half an hour, but the result is the same every time. I don’t really know what to look for in the bootloader’s log, but I can post some pictures of that if it would help.

Haiku boots fine from the same USB stick on the two other machines I tried, one of which is a Dell all-in-one with a very similar BIOS and fairly similar specs (which reminds me, the problematic laptop has 32GB of RAM instead of whatever it came with (16GB IIRC). could that be the issue?)

This isn’t a huge deal since I can use one of those other two machines that work fine, or a VM, but it would be nice to get native performance on my daily driver laptop :slight_smile:

The bootloader log would definitely help, you can enable it from the haiku boot menu, feel free to post the pictures of it.

Here are are all 3 pages of the log:


You can try various boot options (safe mode, failsafe graphics, etc) from the bootloader menu. To get into the bootloader menu (on an UEFI system) you have to press space directly at the start (before the Haiku logo appears)

For more information see here: Boot Loader

1 Like

Haiku’s EFI Bootloader has a few limitations, try to set your BIOS in Legacy Mode if you can.

1 Like

@BlueSky: thanks for the advice but as I said in my original post I’ve already tried various boot options. It would be good to have some pointers to which ones to use though, because I don’t know if I’ve tried the “right” configuration given how many there are (not to mention all the system components!)

@ChronicBoredom: unfortunately it looks like this laptop doesn’t support legacy BIOS mode. According to Dell this is “working as intended” so unless there’s some hacky way to enable it I don’t think I can

Oops, sorry. :see_no_evil:
I obviously didn’t read your post carefully enough.

Looking at the log it seems like an issue with packagefs, not sure if any boot options can help here. We’ll have to wait until someone with a bit more knowledge about Haiku’s boot process chimes in.

1 Like

Please open a ticket at