Cant boot, AT All"

So. Wanting to check out this OS. I have a computer that is only used for watching streaming TV so don’t need/want windows and this looks like the perfect solution.

The problem is nothing I try can make a bootable usb. The haiku on a stick* does not work. I’ve tried to use the iso and the anybootimage with it. ((I forget which one seemed to at least appear to work) (the other wasn’t even seen)) .
Haiku on a stick said congratulations etc but the usb was empty (I do have the proper usb selected.
I also tried the Windiskimage program and several others online that seemed promising.

The closest I got to a working boot was from the Windiskimage program. It loaded to a Haiku logo then the icons under that I think became more colored BUT then it just went to a black screen saying “Unsupported format”

I should say that I tried the download from a few different sources here and from a few different formats. (zip, Iso etc)

I’m lost now. This looked so promising and I’d really like to try it. Can anyone confirm that the images presently on the download page Do in fact work?
Or does anyone have anyideas as to what I can try now.
My system is presently running windows 10

*P.S.FYI, Haikuonastick download only leads to a “404” error

Hi Garphy,

welcome :).
I would suggest you continue to work with the one from the windiskimage program.
Then i would suggest you press shift while booting and select some of this
here explained safemodes:

:slight_smile: Just play around with this a bit :wink:
If you have any question feel free to ask here or come to the irc…

Hi Garpy!

The HaikuOnAStick site linked from the installation guide seems to work, as well as the download linked from there.

You do try with a nightly image, right?

Using Haiku to stream video from the net seems a bit premature. While Barrett has been working on it and apparently made some headway, it’s still not productively usable. You may be better off with something like OpenElec.



FYI. The default download dropdown on the Haiku-on-a-stick is the one that just lead to a 404 error. No problem though as the nightly builds were easy enough to find.

Your statement about the streaming though is a little bit of a let-down.

I assumed that since it had a browser and could get on the internet I should be able to still go to my favourite sites and watch just like I used to.

I think I might still try it anyway if I can get it to boot.



Thank you. I haven’t tried that yet but at least it’s a place to start.

[quote=Garpy]I assumed that since it had a browser and could get on the internet I should be able to still go to my favourite sites and watch just like I used to.

Websites that are like YouTube “should” work on Haiku, however live-streaming websites like Twitch, Streamup, Ustream, Livestream, DaCast, YouNow and live streaming services on other websites (Facebook Live, Youtube Live etc) will not work until live streaming of audio and video is added to Haiku.

IPTV and Internet Radio will also not work for the same reason (apart from the recently added extra experimental Internet Radio support), while other websites that are like and do not provide an HTML5 web player (only flash player etc or none at all) are also not supported.