Cannot see network device

I tried Haiku on a spare box that I had. It loads find from the USB, but there is no networking.

Pentium D 820
MB Intel D945GTP
LAN Intel Integrated Ethernet

The Network Preferences applet shows no device. Is there a procedure for obtaining drivers? Or is there something else that is the problem?

Have you tried a nightly image?

I tried the latest nightly build 44220, and in fact this allowed the system to see the network device. In addition, ifconfig shows reasonable values, and I was able to ping some well-known websites.

Unfortunately, the web browser is apparently not included in the nightly build. This build appears to be a more minimal system, which is not a complaint, just an observation.

However, that means I cannot do much with the system. I am left with the alpha3 which has no networking, or the nightly build which has no browser. Ok for now, as I am would expect to do to much with Haiku other than play around a bit.

I suppose there are procedures for installing applications and missing parts of the alpha3 release to the nightly build, and the only reason I don’t know about them already is because of my raw newbie status.

Hi jasimon9!

You’re right, the nightlies are kept as minimal as possible as they serve for regression checking, which often entails downloading and trying many revisions until the culprit is found. From Terminal you can use “installoptionalpackage -l” to list all available packages. For example “installoptionalpackage WebPositive” will install the browser.
I’ll see if I can can find anyone to include this piece of info at the top of the nightly image page.


Thanks for your confirmation.

Before having your response, I had already installed alpha3 to a partition, figuring that one way would be to update it to the nightly. I was also thinking that the installer might work better that way, for some reason. That seems shortsighted now.

Seems better to start over and install the nightly, then add packages. Is there documentation somewhere which shows what might have to be added to get the code base similar to alpha3?

btw, I should add that I first heard about Haiku in the IEEE article, The Dawn of Haiku. I tried the alpha3, and had some problems (as noted in this thread and a previous thread). Problems were unsupported graphics adapter (apparently) and no networking. Both problems fixed by nightly 44220, and obviously because of support from this forum!

Great that things seem to fall into place for you!
You can have a look at the ReleasBuildProfiles. Line #22 and following show exactly what packages are in an alpha, #45ff what’s in a nightly.
“installoptionalpackage -l” will list all available packages. Note that “Welcome” (the Welcome and Userguide) cannot be installed in that way, because they’re not “real” optional packages. I guess that is because those would have to be constantly repackaged…

But basically, it’s WebPositive and maybe BePDF, i’d say (and wpa_supplicant until ticket #8603 is fixed.)


Thanks for the clear answer.