Cannot install beta2 on PC circa 2008

I downloaded the newly released beta2 x86(x32) and burned to a DVD.

I tried to boot from external DVD but failed.

It’s trying to look for floppy disk (FD), although I have disabled them

and hangs…

Can you see Haiku boot icons? If yes try to boot into safe mode so you can disable some drivers.

No it hangs. 1st picture.

I know it won’t fix your CD problem, but do you have the option to install on a USB memory stick?


I have problem with balena.etcher now…

use version balenaEtcher-Portable-1.5.73

balenaEtcher-Portable-1.5.73 working…

versions > 1.5.73 NOT working.

Haiku USB boot now working.


glad your problem solved… its can install haiku now?

I will try.

seems my PC is slow due to old age.

After many trials, failed to install.



Then blue / blank screen with mouse pointer.
CanNOT move mouse pointer. Hangs…

by the way,

Under QEMU/KMV, successful…

balenaEtcher-Portable-1.5.100 NOW WORKING


Did you try waiting? The very first time I installed Beta1 on my System76 it took over a minute for the mouse to start to work. From then on and including Beta2 the mouse worked fine from startup.

Yes. Waiting for hours. NO response.

I compared it with another installation.
With QEMU/KVM, it was successful.