Cannot get online after installing Haiku in VirtualBox

After I installed Haiku in VirtualBox, I cannot get online using WebPositive.
I use the default NAT mode in the “Network” section in the VM Settings window.
When I click Preference->Network in Haiku, there is nothing listed in the opened

Can anyone help me? I am quite new with Haiku. Thanks.

In VirtualBox, change the ‘Network’ settings to use the ‘Bridged Adapter’, then select your NIC & then select the ‘Intel PRO/1000 MT Desktop (82540EM)’ as the ‘Adapter Type’. It’ll work!

It works. Thanks!

Bridged Adapter may work but the right selection is NAT.

Eva was unable to use installoptionalpackage script until she switched over to NAT. People should use NAT to avoid having the same connection issue.