Cannot get Haiku to install

I have tried the following on an box that normally runs Windows XP:

  1. Create a USB boot drive from the AnyBoot image (used dd on my Mac).
  2. Try booting from it. Nothing appears on the screen.
  3. Next try BiOS selection of boot drive; USB drive selected, but still nothing happens.
  4. Create a CD from the AnyBoot image (used ImgBurn on Windows).
  5. After what appears like a normal boot load from the CD, the screen is still blank.
  6. Go into safe mode and try several variations; at point where I would think the system should be booted up, there is just a blank screen.
  7. Play around with more safe mode options, including lower level video settings. Still no joy.

Just for fun, inserted the USB drive into my Mac, and Opt-Restart. It does not even recognize the USB as bootable.

Not very encouraging.

Any ideas?

what is your hardware? (chipset, manufacturer, graphic adapter), and what Haiku version are you using? (Alpha3 or a nightly build ?)

Do you see the boot menu if you boot while keeping the key pressed ?


  1. ASUS P5G4IC-M Motherboard
  2. VGA Intel G41 chipset
  3. Intel e7500 chip


Yes, do see the boot menu from both USB drive and CD, but cannot boot from there. My feeling is that it is actually booting, but the graphics adapter is not working to produce a display. Even with all safe-mode options checked.

I had another spare box around, so I tried the USB drive with Haiku in it. It worked the first time. So apparently there was some problem with compatibility on the first box that I tried. But for my purposes this solves the problem.

The second box had a Pentium 820 D chip.

Try a nightly image

With the most current nightly (44220) the system now loads from the USB. Likely problem is solved.