Cannot create BFS partition on GPT drive

I made some room on a Hackintosh drive (GPT drive) for 2 FAT32 partitions (as placeholders). I booted up the latest Haiku Nightly off of a USB pen drive. I went to the GPT drive (with DriveSetup) and can see the 2 FAT partitions. I tried selecting either one and could not reformat either one with a BFS file system. DriveSetup said both were read-only.

Is it not possible to make them writable so they can be reformatted? I tried to bring up GPARTED off of a CD but could not find any way to mark them as writable. In Windows 7, same thing.

Anyone run into this problem before?

https://dev.haiku-os.org/ticket/8823

I hope you din’t mount them?

Right, DriveSetup won’t let you format a mounted drive. The menu option is disabled.

If you unmount those drives can you then format them?

When I un-mount the partitions, I cannot format them. DriveSetup says that they are read-only.

That’s okay. The GPT issues seem to be well-known at this stage so they’ll probably get fixed.

In the meantime, it’s not all that bad to use Virtual Box instead of going native.

WARNING WILL ROBINSON: GPT + OLD-BIOS-SYSTEM = NIGHTMARE