Building Serenity OS. Complains gmp.h not there. but gmp installed

I have development packages installed…mpfr, gmp…yet buil aborts saying gmp.h not found…

unable to copy displayed text from terminal…not copying, can do it on Linux

pl. inform, for gmp.h what should I install?

Tried installing gmp_devel package?

1 Like

This is not shown in haiku depot
But yes i have installed the haiku developmwnt environment

Packages devel and sources are of no use for lambda user. Therefore, they are not shown by default in HaikuDepot. You have to go to enable the display of these under Show menu.

pkgman install gmp_devel

Thanks…this installed gmp-devel…now, the buildscript does not complain gmp.h is missing…

But, it does nothing either…when I give ./ run, the prompt line just jumps down and keeps quiet…no message

Somebody pl. clarify as to why I cannot copy text from terminal and post it on these forums…Linux permits this…It would be helpful to clearly explain these issues

Copy paste works fine here. How do you do that exactly?

If you’re coming from a Linux background, be shure to remember that it is Alt+c to copy from the terminal on Haiku, not Shift-Ctrl-c like in most Linux terminals. And likewise, Alt+v to paste it into the web browser

1 Like

Beside keyboard shortcuts one can use the Edit menu in the Terminal window.

1 Like

I use mouse…behaving erratically…
Anyway, though I had installed mpc, mpfr, it complained of missing .h files…
Installed development p[ackages, based on the example of gmp…now tool chain is being built…will inform the progress

Used to do this on my voidlinux…serenity moved to GCC11, void on GCC10.2…so…

Last time i tried to build Serenity on Haiku it failed. I discussed about this with the Serenity guys, they told me the reason for the fail is the many linux specific things they use. So do not expecte an easy ride, but things could have changed in the meantime.

1 Like