Build gcompris failure with QT5Linguist eror


#1

dear all
i have problem, when do

haikuporter gcompris

it show error:

the package “QT5LinguistTools” reference the file “/boot/system/lrelease”
but this file doesnt exist…

this is after i do upgrade qt5 into latest (hrev52635) x86_64
before upgrade i can build gcompris…


#2

Strange behavior… I cannot compile it in 64bits beta (h52295) with the same error outcome, so it doesnt seem to be related to the haiku version, but other stuff.

Noticed that current version of the recipe points to v0.70 (2016), whereas GCompris version is already at v0.91 (2018).

As this is a children/kid quite interesting software that fits the OS motto (imo), work on this could be worthy (even if it is not native, and comes from the linux side yadayada).


#3

Seems like there is some mess up with the QT dependencies and/or the recipes for Gcompris (mix of both with 100% chance).

You need to install qt5_tools to get the lrelease executable and other tools, i guess.

So the recipe compiles if you add:

qt5_tools$secondaryArchSuffix

to the BUILD_REQUIRES section of the recipe, and go ahead (either install it with the depot, or use the autodependency flags).

Unfortunately for my test system, this collides with llvm-clang versions greater than 6 (i.e 7), so i had to uninstall em to get version 6 and qt5_tools installed.

Edit, with the same patches that Mr Duval did (in same files, different lines), 0.91 works nicely in the beta version:

updatedVer

Uploaded the new recipe + patches to my github: PhHaikuRecipes

@extrowerk Can this be moved to the official recipe git without having to make a pull request for those 2 files?


#4

Please create a PR.


#5

Okkkk, guess i will try to pull some of my pending recipes too.


#6

Please, check if it is solved:


#7

Not sure if it is an error on “our” side (QT) or it is an error on the GCompris side.

The activities are there in 0.91, and if you click where they are supposed to be (I.e., in the cat with the keyboard section), you actually get to work with all the activities and can be “played”.

But their icons dont show in the menu… weird corner case… maybe?


#8

thank you @Pahefu after editing recipe… it build package now…
but icon is not show … issue still same


#9

As i said, try to select an activity type on the top menu and click where it should be to see if the app slides to the kid app, even if you dont see the icon itself.

Magic illusion.


#10

yes… kid apps is running anyway… but it will difficult to choose if we don’t see the icon… isn’t it


#11

Of course. That’s why i said that the error is not being there (files are load ok), but other error that someone has to solve to make this useful, i think.

I’m have no experience on QML to have a peek and fix it. And that counting with the error being on their side, which i dont really believe.


#12

Maybe the app ends up looking for icons at the wrong place?


#13

The command # strace -o ~/Desktop/gcompris_strace.txt /boot/system/apps/Gcompris * would save all the possible info to the Desktop, you can chek it, maybe the program searching for the resources in an unexpected folder. It could be hardcoded somewhere.

* Adjust the command to use the correct path for the binary.

Notes: Do not paste the output into the forum, use a text sharing site or github gist for that.


#14

I already had done the strace a while ago, also watched the “Resorce not found” messages grepping, but nothing seems to be crashing out of the ordinary.

I will see if i can upload the text to some sharing place, and/or keep having a peek on this, yet i’m suspecting some QT unexpected behavior.

Edit: Link for “log.txt” (1.1MB) at first place that appeared on duckduckgo for uploading files. https://anonfile.com/Y9ib05n1b7/log_txt


#15

I thought Gcompris QT5 needed OpenGL. see https://github.com/haikuports/haikuports/commit/2680d9a73daad980a5d343cd349502297d699e95

There is an upstream commit that might help: https://github.com/gcompris/GCompris-qt/commit/a9282b2c9bf6fbd55c529c05500de68bdce17c9f (not yet in any release).


#16

They state that Linux 64bit versions requires OpenGL. However, it’s weird because everything else seems to ve visible.

Applying the patch on the upstream commit and reinstalling seems to not solve the issue (unfortunately) on 0.91+ .

Console doesnt show the new messages, but shows:

This plugin does not support createPlatformOpenGLContext!
failed to acquire GL context to resolve capabilities, using defaults..

Which yep, seems like troubles with OpenGL + QT.