Bug ticket #3663

This ticket states:

Haiku fails to boot. The booting process goes fine, until the desktop is supposed to appear, but only the blue background appears and the mouse is frozen, the system can’t even be rebooted with ctrl-alt-del.

I am have no clue, whether this is related to the recent directory changes or not. The last revision, which I’m sure that it worked was r29805.

This is a fresh image with no prior file lying around, which might cause trouble.

Failing revision is r29881.

Changed 7 months ago by mmlr ¶

Most likely it is a conflict between the hda driver and OSS. The hda driver has been added to the default image and will conflict with OSS if you have the corresponding optional package installed. Please remove either the hda or the OSS driver from your installation in that case.
Changed 7 months ago by rossi ¶

Yeah, figured that one out and are happy again :wink: feel free to close this bug as invalid.
Changed 7 months ago by stippi ¶

* status changed from new to closed
* resolution set to invalid

Ok, thanks for the feedback!

I am having difficulty getting sound to work with the HDA driver and have submitted a bug #4838 about it. In the mean time I installed a Soundblaster Live sound card in my machine turning off the onboard audio option in the bios setup. Then I did a fresh (formatted new partition) installation of Haiku Alpha 1 from the live cd without any optional packages and got the same results as above on the first boot.

I’m guessing that the installation detected my Soundblaster card and provided OSS automatically along with the embedded HDA driver. So I tried removing the HDA driver from /boot/system/add-ons/kernel/drivers/dev/audio/hmulti and /boot/system/add-ons/kernel/drivers/bin. This doesn’t fix the problem for me like it did for stippi, using r29881.

My question is does the kernel always look for the HDA driver because its been added to the default image, even after removing the actual HDA files and will I ever be able to use my Soundblaster Live in Haiku?

I’m not terribly good at hardware/driver questions, so take a few spoons of salt with whatever I say…

I may be wrong, but I think OSS wasn’t part of alpha1 (because of the animosities with native drivers). When Haiku finds your HDA onboard chip, it tries to load the driver for it (even if it turns out it doesn’t work with your particular HDA flavour, apparently). If you remove that, it can’t find it and therefore ignores that device like any other it doesn’t have a driver for.
Now, if you install the OSS optional package, and OSS provides a driver for your SB, the OSS-SB driver should load instead.

Or did I misunderstand, and you can even boot up Haiku?

Regards,
Humdinger

Thank you for the reply, Humdinger. I’m sure whatever you say, even unsalted, will help a noob like me.
I can boot Haiku if I remove the soundblaster card. I may have misspoke when I mentioned turning off the onboard audio option. My bios setup offers disabled (no sound) or auto (choose your device). I boot openSUSE and Arch as well as Haiku. The other OS’s have the option to choose a device in their respective Media preferences tool. I’m thinking that since both audio devices are made available to the OS by my bios, that Haiku has a conflict about which one to load a driver for, even if I’ve removed the HDA driver. I haven’t installed the OSS driver this time as I noticed a emuxki driver in /boot/system/add-ons/kernel/drivers/dev/audio/hmulti and thought that might work for SB Live.
I will try removing the sound card booting into Haiku and installing OSS and report back my results.

if you remove the hda driver then it should work with OSS.

You may have a audio card issue, OSS may detect your hda & SB chipsets and not sure which to use. Disable your on-board audio in the BIOS.

do “ls /dev/audio” and same for all the sub-folders. That will show what audio driver was loaded for you.

Check Preferences -> Media. This controls selection of audio card and audio settings. Does it display a sound card?

Edit: you’re right Haiku has a native SB driver which should kick in with the right SB card - shouldn’t need OSS for it. Can you provide listdev output for the two audio cards only?

I disabled the audio in the BIOS and to my surprise my linux distros still played audio through my SB card. I removed the SB card so I could boot into a fresh install of Haiku and moved the /boot/system/add-ons/kernel/drivers/dev/audio/hmulti folder and all the drivers in it from the /boot/system/add-ons/kernel/drivers/bin folder to trash. I downloaded the OSS driver from the Haikuware site and expanded it into /boot. I rebooted into Haiku successfully, then shutdown and replaced the SB card, rebooted and saw the splashscreen with a text message at the top “PANIC: acquire_spinlock: attempt to acqiure spinlock 0x81d01a10 with interupts enabled” at the bottom of the text strip there is a kdebug> prompt. When I type help it list MANY commands. “sc” looked like it might be useful. Of course I’ll need to transcribe the output with pencil and paper and boot linux to post them.

I couldn’t do the listdev for my SB card since I still can’t boot with it installed. I can remove it again to be able to boot into Haiku and listdev my onboard audio device if you think it would help. Below is the output of “lsdev” from a bash shell in Arch linux.

0000:00:11.0                 fb00-fb0f fc00-fc03 fd00-fd07 fe00-fe03 ff00-ff07
0000:00:12.0                 f600-f60f f700-f703 f800-f807 f900-f903 fa00-fa07
0000:00:14.0                 0b00-0b0f                                        
0000:00:14.1                 0170-0177 01f0-01f7 0376-0376 03f6-03f6 f400-f40f
0000:02:02.0                   dc00-dcff
0000:02:03.0                   df00-df1f
0000:02:03.1                   de00-de07
8139too                          dc00-dcff
acpi                      9
ACPI                           4000-4003   4004-4005   4008-400b   4010-4015   4020-4027   4050-4050
cascade             4
dma                          0080-008f
dma1                         0000-001f
dma2                         00c0-00df
EMU10K1                  16      df00-df1f
emu10k1-gp                       de00-de07
eth0                     21
floppy              2     6  03f2-03f2 03f4-03f5 03f7-03f7
fpu                          00f0-00ff
i8042                  1 12
keyboard                     0060-0060 0064-0064
ohci_hcd:usb3            19
parport0            3     7  0378-037a 0778-077a
pata_atiixp           14 15    0170-0177   01f0-01f7   0376-0376   03f6-03f6   f400-f40f
PCI                          0cf8-0cff d000-dfff e000-efff
pic1                         0020-0021
pic2                         00a0-00a1
pnp                          0228-022f 040b-040b 04d0-04d1 04d6-04d6 0800-087f 0880-088f 0c00-0c01 0c14-0c14 0c50-0c52 0c6c-0c6d 0c6f-0c6f 0cd4-0cdf 4000-40fe 4210-4217
rtc0                      8  0070-0073
sata_sil              22 23
timer                     0
timer0                       0040-0043
timer1                       0050-0053
vga+                         03c0-03df

I’m afraid, I can’t help you here. You should file a bug report at http://dev.haiku-os.org with all the info.

Thank you for all your responses Humdinger. I’ve done some googling on “acquire_spinlock” and it looks like the Soundblaster Live card is the culprit. I removed it reinstalled Haiku on 2 separate partitions one with the HDA the other with the OSS driver. The OSS driver finds my audio device, but it doesn’t have any sound output . The HDA driver doesn’t find my audio device (bug #4838). I’ll file a bug about the SB card issues and wait for my other bug to get addressed. Meanwhile its better to be in Haiku with no sound than not be in Haiku at all.