Botched Haiku install, no more LiveCD?

So, I was installing Haiku on my netbook (Asus eeepc 900) and my power strip got kicked and killed power to my system and my external CDROM drive. No problem! I wanted to change some things anyway! However: when I tried to boot the LiveCD on that system, it never worked again! No matter if I had the original install-to disk connected or not, I always got dumped into the kernel debugger with a boot partition not found error. Obviously, some flag got set on the system that says “Haiku is already installed, so look for a boot partition.” Is there any way to reset this flag? Plus (and this might be bug territory), somebody might want to boot the LiveCD even if the Haiku partition is present and healthy. Any quick suggestions? Or do I need to go source-code exploring?

Thanks! Plus, to all Haiku developers: My God, it is so nice! You guys have done an incredible job!

Hold the space bar while booting(at the start), and then change the boot device to CD-rom. :slight_smile: