Boots to three pc's but trying to get it to boot a fourth machine fails

I have Haiku on a usb stick booting and running well, wireless etc, on 3 PC’S. These are older low spec units with low RAM. I would like to boot Haiku on a laptop with 8gb of RAM but it boots to ‘Invalid Partition Table’ then to ‘Boot Loader’ which says ‘Boot Volume Not Valid’.
The usb obviously works but I need help to get it to boot on this third machine…which isn’t that sophisticated…Dell Latitude E6330
i would appreciate suggestions.

The maximum address space of a 32 bit bus is 4 GB. Try using the 64-bit version.

Hi Sam, I had considered that but the install to the USB declares itself as 64-bit but I will check that out further and let you know…thanks

Downloaded the 64bit iso & set it up on a USB…booted up that USB but got the same result ie 'boot volume not valid.

How are you booting Haiku? Boot sector or UEFI?
Did you check BIOS to see if there’s an option like secure boot enabled?
Do you have other USB ports that you could try on this machine?

Set for legacy boot not UEFI, secure boot disabled and I have tried the other 3 USB ports…this laptop is a dual boot with GRUB managing Win10 & Linux…does GRUB influence USB booting of Haiku?

The 32bit version of Haiku uses 32bit virtual addresses, but 64bit physical addresses if available. So it is not a problem to use it with more than 4GB of RAM. The only limitation is that each application can only use about 3GB of address space.

4 Likes

It would help to have screenshots of these errors to know who’s returning them exactly.
It seems that the system tries to boot from USB but doesn’t recognise the partition scheme and so give the message ‘Invalid Partition Table’.
Generally, what happens in this case is that BIOS will try to boot from the next media in the boot list. Here it seems trapped by the boot loader looking for an active partition.
If you have the possibility to boot from an optical drive on this machine, it would be worthy to try if you can arrive to desktop mode.

This unit doesn’t have an optical drive. When I insert a USB drive with another OS on it, say Ubuntu, the PC boots OK. I used the install path suggested…that is, I booted the ISO and installed from there to another USB. This doesn’t create a partition scheme as such but reflects the ISO. Perhaps I need to find another way to do the install.