Booting Troubles


Hi Everybody !

I am impressed by the Haiku zippyness.

I have searched through the forms and I haven’t found a similar mentioned problem.

I have a Dell Inspiron Laptop

I have partitioned my drive in an attempt to dual boot

I followed the installation guide.

I see Haiku and all of the files installed on my hard drive.

I can not boot up into the Haiku at all.

I have it as Haiku as an option for Grub but it boots to a black screen

No key seems responsive during this part.

If I try to boot by the disk, I am presented to with the boot screen but no options.

Any ideas?

Thank beforehand for any help.


Did you hold the SHIFT key while choosing Haiku from the grub menu? Or alternatively, keep hitting SPACE? That should land you in the boot options.


I tired both holding the shifts and hitting the space bar when selecting Haiku. I still got a blank screen but my computer speakers made popping sounds.


Just to make sure: You do keep holding SHIFT (or hammering SPACE) after selecting Haiku, right? Other than that, maybe it’s an issue with your hardware… if you have a USB keyboard laying around, try with that.
Other than that, I have no idea why you wouldn’t land in the boot options.


I tried it again with an external keyboard with the same results.

I am just perplex as the live CD works fine.

It almost seems as if Haiku is invisible to both the the CD bootloader and Grub.


Hi :wave:, just my two cents: You can use your LiveCD to boot the system from your hard deive. In this way, you can at least check that the installation process was OK.

To do so, if I am right, you need to boot from the LiveCD and, while booting, press the space key to select a different volume to boot from.

I used to do that when I had a Haiku drive in my Windows machine and I didn’t want to change the boot system.

I hope you solve the problem.

Kind regards


Another stab in the dark… :slight_smile:
Are you sure you ticked the “Active partition” checkmark when you created the partition in DriveSetup?


@cnelmortimer I can only boot the LiveCD and not from my hard drive. When I go to the LiveCD bootscreen menu I get only the option to boot from the CD.

@humdinger With a confusing problem, I think the problem is either really easy or really complicated. I am just going to assume/hope it is really simple. How would I check or mark that I ticked “Active partition”?


I’m not quite sure if you can… You could boot the CD, start DriveSetup and delete and the re-create the partition, making sure the checkbox is ticked. Then use Installer once more to install Haiku. Thankfully, it’s all done pretty quickly… :slight_smile: