Booting Haiku Help

I can’t seem to boot haiku. I downloaded the latest source code as of today and complied it using the folowing commands;
makehdimage /test3

then I ran bootman and added that partition to the boot loader. When I try to boot off that partition I get the Haiku logo, but then it just sits there with no HD activity. I have trided all the spacebar options to no avail. Did I miss something? My system specs are as follows;

Athlon 1.4ghz
512mb /w full ECC
Some cheap NIC
No floppy drive.

Since nobody in-the-know has answered so far, I’ll add a few comments.

First of all, Philipp Schmid has posted a Haiku build howto on his blog.

In addition to that, some weeks ago, I also tried to build Haiku from one of the source code snapshots, but that didn’t work. After that, I went the other way, installed subversion, and checked out the Haiku source code that way, and it has been working (and booting) flawlessly since then.

Thanks for the tips!

" I also tried to build Haiku from one of the source code snapshots, but that didn’t work." Did it fail durring a compile or boot? I guess I could bite the bullet and subversion it.


I got a BUILD FAILED message, and it didn’t, IIRC, install anything. So you decide whether a subversion checkout is worth a try.

Of course, the thing is: initially it’ll take a long while to check out everything, but after that initial step, keeping the source code up to date through subversion will save you a lot of bandwidth compared to always downloading whole new archives (since subversion will only download the modified files) if you want to upgrade, so I’d recommend it.

As I said, it takes a while, but it’s much better than a Gentoo stage 1 install, if that’s of any comfort to you :wink:

Nope, compile from source did not help. I just hangs at the haiku logo. I guess it does not like my computer :slight_smile: I’ll try in a few weeks and see if newer code helps.

It’s entirely possible that Haiku isn’t playing very nice with your hardware just yet. It doesn’t quite work right on the machine I do all my development on - the input_server doesn’t run. My edjumacated guess is that motherboard chipsets have a something to do with it. What kind of motherboard do you have?

Well I played with every setting in the bios and now it seems to boot. I’m trying to track down wich setting it was but so far it seems to be “PCI/VGA Snooping”. Weird. But now it boots fine, but no mouse or KB support. I think I have a ABIT KG7 mobo with a AMD 760 chipset. So either its a kernel/driver bug or the input server does not work like yours. I do have a USB mouse, are those supported?

PS. Been keeping tabs on the CVS entries on CIA, keep up the great work DarkWyrm.

I’m not sure if USB mice are supported - I don’t know how far Niels has gotten with the USB stack. Sorry.

DarkWyrm wrote:
I'm not sure if USB mice are supported - I don't know how far Niels has gotten with the USB stack. Sorry.

They work in ‘legacy’ mode when they pretend to be PS/2. Doesn’t work on a laptop though, as the trackpad takes the damn ps/2 port…

Since I don’t really know where to post a message such as this, I’ll use this thread…

For some days, I’ve had problems with the keyboard and mouse. For a time reference: I think it started when I checked out the sources a day or two after the Haiku logo was made to appear on the lower right corner of the desktop.

Mouse and keyboard suddenly didn’t work anymore. This continued through a few svn updates. About two hours ago, I checked out the latest updates from the SVN repository (rev. 13223, I think), and additionally deleted the /Distro and the /objects folder before calling the makehdimage script, so that everything would be newly built.

Now the keyboard seems to work again in MiniTerminal, and I can move the mouse downward. You read it right, I can move the mouse pointer downward at the left edge of the screen, but not right or up (left I can’t check out, for obvious reasons… :wink: ).

I’m using a normal PS/2 mouse and keyboard, and both have worked in previous revisions.

Seems like a quite weird problem…

How usable is haiku at the moment? Is it as usable as Zeta? Im still quiet confused on how much progress they have made in Haiku…

It’s not as usable as Zeta. Most parts are still getting coded on.