Booting BeOS MAX (or Haiku) with Grub 2?

Has anyone had any luck booting BeOS PE5 MAX, or Haiku, with Grub 2?

I am using ubuntu linux on the same machine. I was using a version that came with Grub 0.97 (I think) and I was able to boot using the following menu entry:

rootnoverify (hd0,5)
chainloader +1

The ‘rootnoverify’ was required. I could not boot without it.

I upgraded to ubuntu 9.10, which now comes with Grub 2 by default. grub didn’t automatically discover the BeOS partition, so I had to add it to the 40_custom file, and run update-grub to add it to the menu. I used an entry just like the one above.

When I rebooted the machine and tried to boot BeOS, grub informed me that rootnoverify was no longer a valid command. I tried changing it to root= but had no luck.

Anybody have any suggestions? Thanks!

on edit: I am sorry, it looks like I posted a thread that someone else already started. However, the suggestion in that thread did not work for me. :frowning:

Below should work for you.

Similar thread here: