Boot to black screen, my fault?

Good morning,

So I’m suddenly booting to an entirely black screen.

Yes, I’m an idiot, and yes, I’m running nightly.

If it helps, my dumb ass used the key combo shitf/ctrl/alt/esc.

So, what did I do? Am I facing a reinstall? It’s okay if that’s what I have to do.

Hi. A bit more of information could be useful: this is the first time running Haiku? Happened right after an upgrade? Was working fine and suddently started to fail and lands you into the black screen?

Did you tried to use the safe video mode (holding the Shift key or pressing the Spacebar during the booting process)?
Use fail-safe video mode


Not first time, but I’m still pretty new. Recent install. I did upgrade this morning, and I think it was after I installed Boxedwine that my problems started. I tried that key combo to close the window, but I think I got the combo wrong for the “Vulcan Death Grip.”

I am currently booted with default graphics in safe mode.

Still investigating.

I have no problem getting my hands dirty in config files, terminal, etc.

But my technical knowledge only goes so far, so I must defer to those with more advanced experience.

Fortunately, if I must do a nuke and pave it doesn’t matter, as this is an older laptop that would otherwise be in a landfill.

ALT+CTRL+SHIFT+ESC only switches the current workspace to a “safe” setting (800x600x16, at least here). You should be able to blindly boot into the black screen, and switch to workspace #2 with ALT+F2 and have a working screen.
From there, open the Screen preferences and set “All workspaces” to the correct setting.

Hope that helps. Otherwise you may want to boot in safe mode and try removing ~/config/settings/system/app_server/workspaces. Then reboot.

The Vulcan Death Grip ™ is SHIFT+CTRL+OPT+ALT and clicking the app in the Deskbar. :vulcan_salute:


Thank you! I’m going to save your answer to my Haiku Help File.

I had to correct the Vulcan Shortcut, no OPT needed…

You find infos on those shortcuts in the User Guide under “Deskbar” and “Screen”, too.


Thanks so much! I really appreciate all the help, and honestly, I’m fucking happy to be here, and to contribute in some small way. I’m not yet in the daily driver camp, but as a man once said, “buy the ticket, take the ride.”

Well, I downloaded the ticket, will donate cash when possible as well.

And I am back to my desktop, with the added bonus of Workspaces being displayed normally.

Before this, for the last several days, the replicant showed all the spaces as black, rather than default. So this is progress.

1 Like