Boot-Manager Problem? Rather ? Installer <> DriveSetup problems ?!

Moin from East Frisia
Some time ago I installed Haiku using balenaEtcher under Win10 on a USB stick (Haiku).
After that sometime from there to the rest place (Haiku64).
Initially I had both Haiku installations entered in the boot menu, but that only worked on one machine (selection).
The other two machines always booted the first Haiku installation without asking, without showing a boot menu (selection).
So I removed the entry of the first Haiku installation (Haiku) from the boot menu, so that only the second Haiku installation remained as entry.
The first computer shows (correctly) only the second entry (Haiku64) in the boot menu, the other two computers continue to boot (without asking = without displaying a boot manager) directly the (*Edit: FIRST Haiku installation (Haiku).
What can I do to fix this?

*Edit

Translated with www.DeepL.com/Translator (free version)

If you are using EFI booting, the boot menu is currently not available. You will have to set up rEFInd or another EFI bootloader instead.

1 Like

Thank you very much for your reply!
It would be helpful not only for me but especially for all ‘newcomers’ if this problem (and some others related to booting and installing) were solved software-wise.
EDIT:
So without detours…
On Haiku64 I have already installed a lot of software, so I would like to keep it as it is.
How can I make it (as easy as possible) that on all machines only Haiku64 is booted directly (without using the boot manager)?
Is there any way?

Who can tell me how to get rid of the boot manager I definitely did NOT install!
There is no remove offered (grayed out) for either of the 64bit Haiku installations (1. SSD internal, 2. USB stick), although this option should be available.

IIRC you can set the timer to “0” in bootmanager, that way it won’t pop up? (been a long while though since I checked there).

1 Like

Rather ? Installer <> DriveSetup problems ?!

Maybe messy (for insiders and command line junkies):

  1. 32bit and 64bit Haiku installations deleted from my Zotac box (fully 32bit + 64 bit Haiku compatible) and set up as a single partition for 64bit Haiku.

  2. Installed 64bit Haiku from the USB stick (2nd partition there) to the Zotac box.

  3. Created a partition for Haiku on the USB stick and installed Haiku-64bit from the Zotac box on this stick.

  4. Result:
    After selecting boot menu (computer) I get on the Zotac box the display:
    Haiku Boot Manager…, although I have NOT installed one!
    When I select ‘Set up boot menu’, I get the two internal SSD drives displayed, but even after clicking on the Haiku-64bit LW, the ‘Remove’ button remains grayed out.

  5. Curiosity (or not?):
    When I select the boot menu (computer) on my newer Zotac box, it does NOT show me a USB stick to choose from.
    This machine had previously (1st Haiku64 with balenaETCHER, 2nd Haiku64 from there to the 2nd partition behind it) always booted the 1st balenaETCHER installation without offering the 2nd for selection. But worked excellent!

  6. On the (newer) MSI laptop also started the first balenaETCHER installation, quite great in native resolution and very fast to rocket.
    This computer does not start Haiku64 now over skin!

Am I annoying?

Danke, ich schaue später nach.

1 Like

Unfortunately, this did not help, the boot manager still flashes briefly!
BootManager:
A volume must be selected on which the boot manager can be set up or REMOVED.
Why does the REMOVE button remain grayed out - when I just want THAT: REMOVE the boot manager?

EDIT1:
ScreenShot of the Zotac ZBOX IQ01
By the way: Ancestris 12 works (almost) perfectly!

EDIT2:
ScreenShot of USB-Stick on the Zotac ZBOX IQ01
USB-Stick-BootManager-ZotacZBOX-IQ01

If you are using BIOS mode booting, and still want to get rid of whatever boot menu you have there, Haiku has a tool called “writembr” that seems to write down a “generic” MBR IPL code block that should boot Haiku with no menu (AFAICT).

I haven’t personally tried (I’m just really happy with BootManager’s boot menu), so…beware! And use it under your own risk; as you should, anyway, with tools that deal with vital parts of your storage devices.

1 Like

Thank you for your comment!
So then the option ‘Remove BootManager’ is just a (future?) feature which is not really implemented at all?
Why not start the tool you mentioned “writembr” by clicking on the ‘Remove’ button, if it really works as you think!
By the way:
Haiku is installed on my older Zotac ZBOX IQ01 as sole OS, otherwise it should ONLY be tested via USB stick on the newer Zotac ZBOX and on the MSI Game-Book.

It seems to me that Installer ?, DriveSetup ?, Boot Manager ? are in urgent need of an overhaul!
I virtually drop my pants in this regard, but how many interested people give up without commenting here?

When you use BootManager to install the boot menu, it saves a copy of the present MBR (it writes it as /boot/home/config/settings/bootman/MBR).

The Restore MBR option would only work if that file (/boot/home/config/settings/bootman/MBR) exits exists. At least that’s my understanding.

Could it also offer to write a generic MBR code, besides the current “Install boot menu” and “Restore saved MBR”? Sure. But currently it doesn’t.

Or maybe there’s another bug in there preventing it to work?

See if there’s a ticket already open about that on https://dev.haiku-os.org, and if not, open one to suggest that feature (or report the possible bug).

1 Like

MBR restoration appears to be broken for over a decade: #9014 (Uninstall button not available) – Haiku

1 Like

Indeed, restoring a mbr is impossible without an image of it. Unfortunately, people often think about it, after initializing and installing again and, at this time image is lost.
If people were using boot manager, you have to assume that they had several systems installed and it is really difficult to know if there are other systems installed needing it. You could have another disk using UEFI and select disks to boot from BIOS menu, for example.
Before offering ‘Restore normal Haiku boot’ and write a generic mbr, you would have to check every disk for another system, and for safety, disable the option if one or more is found. In practice, that wouldn’t be very useful.

1 Like

I would like ONLY:
Test Haiku 64bit on real hardware (multiple computers = 4) using BOOT from a USB stick (+ software installed on it) - nothing more!
So again from the beginning:

  1. from the USB stick with balenaETCHER Haiku 64bit (600 MB partition?) booted all 4 computers!
  2. because I would like to update this Haiku and also wanted to test software.
  3. i installed (as described above) another Haiku 64bit in the free space.
  4. all 4 computers booted further Haiku 64bit, but 2 of them exclusively the first (belanaEtcher) installation, which I did not notice immediately.
  5. after the detour over the SSD of the Zotac ZBOX IQ01 I installed from there Haiku 64bit incl. already installed software on a single patition on theUSB stick.
    Unfortunately a BootManager was probably also installed with it???, or have I verzapft this myself without still remembering it?
  6. now only 2 computers boot, of which one at least offers me the USB stick as boot-LW for selection - but after that Windows boots. The other computer boots immediately after Win.
  7. how can I install a (sole) Haiku 64bit on the USB stick that it behaves like the to 1. balenaEtcher installation? (which boots all my 4 computers) and uses the entire capacity, so can be updated and has space for software???

Just install Haiku to the usb stick the same way you would install it to an SSD/HDD, then open a terminal and type
writembr /dev/disk/usb/0/0/raw.
(make sure the usb stick is the only one plugged in when you type that cmd).

1 Like

Thanks, I just followed your instruction - down here on the Zotac ZBOX IQ01.
But I still have to test it later upstairs on the two ‘problematic’ computers!
writembr

From my Zotac ZBOX (F8) after ‘writembr…’ the USB stick is shown as ‘SanDisk’ and from my DELL laptop (F12) as ‘USB Storage Device’ as boot device and in each case after selection Haiku64bit is booted.
On both computers a flashing underscore ‘_’ is displayed briefly before booting …?
The DELL screen shows Haiku only dimly, i.e. without backlight?
The newer Zotac ZBOX (F8) also shows the ‘SanDisk’ as boot device, but after selecting it, no Haiku is booted, but Win.
The even newer MSI Gaming Laptop does not boot Haiku at all now.

EDIT:
Thanks for trying to help!
Too bad about the wasted time!

This and similar ‘problems’ should be fixed as soon as possible!
Such ‘stumbling’ blocks certainly deter many interested people from further haiku tests.

Yesterday I reserved a new USB stick for Haiku (haiku-master-hrev56921-x86_64-anyboot).
All my four (4) machines are now booting on real hardware!

… after I reset the BIOS of the two newer computers to the delivery state…

2 Likes