Black screen after "rocket", no chance to enter bootmenue


#1

hello, I wanted to try the nightly and I have a system with a core i3 2100 using the intel gfx via HDMI to a 3k display … but after the last icon from the bootloader gets colored - the rocket - display went black. I tried enter the bootoptions with space or left shift but no chance.

regards,
tlb


#2

You can enter the botmenu then you enter spac during the boot sequence?

Try the vesa graphic mode.


#3

Make sure you hold down the shift key from the beginning of the boot process, best right after the BIOS post is printed. If you use a USB keyboard, maybe try another port… I don’t know…


#4

https://www.haiku-os.org/docs/userguide/en/bootloader.html
https://www.haiku-os.org/guides/daily-tasks/blacklist-packages


#5

On first boot it will take some time after the rocket icon to start Haiku the first time. Wait some minutes… At least 5min… Maybe it helps…


#6

entering bootmenu - not possible like stated above
not with pressing “space” on/off or holding down “left shift”

the mainboard is an Intel DH67BL from 2010 without

  • W8/W10 FAST boot stuff
  • without PS/2
  • USB keyboard is connected to a USB2.0 port.

it is not the “first boot” after an install, I try to boot into “selector” where I can choose between “setup” and “live-medium”


I think haiku inits the DVI-port w/o a display connected, instead of the HDMI-port w/ a display connected.

so it’s 2017 and:

1.) HDMI is not that new to the market
2.) more and more displays have no DVI

solution: maybe a txt-config-file inside the iso / on the usb boot stick ?

I will try to get an DVI-HDMI-Adapter, so I can use the DVI port.


meanwhile, I tried haiku on my notebook (i3 broadwell), getting pretty early into kernel debugger …


#7

From the hardware side, DVI and HDMI are almost identical. The only differences are the physical connection, and that HDMI extends the protocol to also carry sound (and we don’t support that anyway). So they make no difference for us.

However, it is possible (I’d say unlikely, but you never know) that the intel driver picks the wrong port. It’s also possible that it picks the right one but fails to initialize it properly.

There is a settings file to force VESA mode, but it is inside the BFS filesystem. So you will need something that can write to it. This is why we also have a boot menu, which should be easily reachable by just holding shift while the computer boots (even before Haiku starts to load). If that doesn’t work, I don’t know what to suggest, since this is all handled by using the BIOS routines at this early point in the boot. So it can’t even be a driver problem on our side.


#8

but with MS Windows or some Linux distros I’m able to

a) get a picture via HDMI
b) enter boot menu

on this machine.

so haiku seems to do things wrong and me ending up not able to use haiku on real hardware.
I can run it in VMWare.

So I have two machines (one from 2010, one from 2015) unable to boot or even use haiku.
This is a strange situation …
Do I need older hardware ?
I know behind haiku is not the same manpower like MS Windows, Linux, OSX …
but people like john doe must be able to run haiku w/o hacking the installation medium w/ special tools …
to get a broader userbase, which results in more input in the project ???


#9

I use Haiku with HDMI there is only no sound, so I use a audio cable too…
you should try the Live-CD first… and if it doesn’t work your hardware is not supported yet.


#10

On some machines Haiku may not boot from CD/DVD, but will boot from USB flash or HDD/SSD.


#11

I’m back … playing with the sandy bridge system (DH67BL), but this time with a E3 Xeon 1260L as CPU and haiku R1beta1 and a DVI-D cable using DVI output of the Intel CPU into a DELL 1080p monitor.

booting from DVD = crash into debugger after “Mounting boot disk” during “Loading CPU specific modules”, usb-keyboard not working, no input possible

booting from USB-stick = blank screen after rocket, Dell display getting no signal, goes into power save

booting from USB-stick with holding shift = not stopping, so still no chance to enter VESA safe mode, so outcome is same as without holding shift

so over a year has passed and the situation is the same ?
sad.

to do more testing I need a prebuild image with VESA safe mode enabled or the possibility for me to easy change a configfile in a (ex-)FAT(16/32) partition from windows on the bootmedium.


#12

Are you holding the Shift key before the Haiku logo appears?


#13

yes, like:

a) from power on
b) at the moment see BIOS output

in both cases I hold down shift before any screenoutput from haiku appears