Black borders around display, overscan?

I have messed with Haiku before, but only just now decided to give it a real go and install on hardware, not virtual machine. I’ve got it installed, and it boots just fine, and runs great. Only thing is there is a 2 inch black border around my display, i.e. the Haiku desktop does not go all the way up to the edge of the screen.

I’ve had this problem before using this screen (it’s a HDMI one), using my Raspberry Pi, and RISC OS and also Plan 9. Each OS had the black border and each could be resolved by disabling overscan in a config file.Is it possible to do this on Haiku? Otherwise it’s working great, so fast on the tiny little Atom processor, networking is fine, it’s just the display before it’s perfect.



Question: Have you checked for overscan options in your menus?

I have two TVs and one monitor that sometimes will not auto-adjust properly. Often just turning the display off and on will fix the problem. (No I have not been watching too much IT Crowd)

But sometimes I have to go to the control panel and adjust some settings to make them work.

Welcome to the Haiku shell.

~> listdev

The problem is that most likely Haiku doesn’t have a driver for your graphic card so it uses VESA driver which in turn can only use resolutions listed in the VESA BIOS of your graphics card.

However, you could try to use Clover, a third party bootloader available at which can patch VIDEO BIOS on the fly. It doesn’t work for every possible chipset out there, but you can give it a shot. Check out this ticket too

Thanks both for the help.

I have tried some setting on my screen, overscan off and on etc. does not seem to make much difference. Perhaps I will try to install Clover and see how I go.