Beta 3, Screen Resolution Flickering


So, I just changed my screen resolution to something far too high, and now I cannot figure out how to get it to stay configured correctly. I have attempted safe mode, as well as booting to a known good state, and I am still stuck with the incorrect resolution. I am considering a reinstall, but figured I would check in here first. What is it that I’m doing wrong? It’s a Dell Optiplex Laptop, standard Intel chipset. Came with Windows 8 I think.

You cannot boot into Haiku, because the screen is scambled?
Have you tried “Use fail-safe graphics driver” and choosing a working screen resolution there from the boot options (booting while holding SHIFT)?

Once booted into VESA mode, try deleting Use fail-safe graphics driver /boot/home/config/settings/system/app_server/workspaces.

1 Like

I just remembered: Even if you cannot see anything, because of the scrambled screen, you can press SHIFT+CTRL+ALT+ESC to enter a safe screen mode. Once that set, you can open the Screen preferences to set the correct resolution.


Thank you! I’ll check it out when I get home from work.

So, I just tried this, and all I have is a black screen. I’m off to Google to look into it further.

The best way to get help is here!
Or on IRC: IRC Channels | Haiku Project
Haiku Bug tracker is here:
If you changed to a different resolution and it will not work, wait 5 sec to be back to the previous res…

Edit good to try the startup options: Boot Loader

1 Like

Thank you so much! Crossing my fingers that my booting into safe mode and setting the resolution correctly will have solved it.

I ended up just booting with the failsafe graphics driver option and I’m good. Thanks!