BeOS R5 install on ThinkPad x60s

Hello,
I need to install BeOS R5 on a ThinkPad x60s but it hang at the PCI device icon.
Anyone has an idea?

Boot menu, and disable all the extra stuff? That is what I would try. Disable BIOS calls, use failsafe video, etc. You can also make it log to the screen what is going on so you might see why it is hanging.

this have no effects.

Maybe try the BeOs Max? There is a 4GB patch IIRC

have you a iso url ?

1 Like

Zeta is also quite easy to find…

Hmm last version of max was v4b1 I think. I have it installed in virtualbox but can’t find the ISO. Edit: Ah here it is, along with PhOS, zeta and … everything: BeOS, Be Inc. - Старый DOS. Abandonware, старые игры и программы - скачать!

1 Like

How much RAM does it have? The RAM limiting bootloader is needed over ~800MB (depends on video RAM and other factors); BeOS Max and PhOS probably both have it, but you want to go back to a cleaner install that’s what you’ll have to add.

That machine is at the very end of the era of machines that run R5 really. There’ll be VESA graphics, no Wifi, but there should be a driver for the gigabit ethernet. I don’t think there was ever a HDA driver for R5, OSS 4 might work if you can find the files for it.

You probably need the patches for SSE support on that machine, it is too modern for plain BeOS R5 to work. This is integrated in BeOS Max or in BeOS DevEd (both are “distributions” of BeOS R5 with several patches, updates, and extra software preinstalled).

1 Like

Who was developing BeOS Max?

Quick google search lead to this: BeOS Max Edition v3.0 Released – OSnews which in turn prompted a trip to the Wayback Machine : Looks like a Vassilis ‘vasper’ Perantzakis organized it.

2 Likes

Hi,

I spent some time trying to make this work on an X60 - very similar to your X60s. Also an X61 which is pretty much the same except for the Core 2 duo instead of core duo.

The short version is the keyboard and trackpoint fail.

The long version is that if you pre-install on a hard drive, set the bios for ide compatibility instead of sata, have exactly 1GB of ram and use the default zbeos boot loader you can boot to a running beos desktop - but no keyboard or mouse. Reducing ram to 512mb or using the ram limiting bootloader is for whatever reason incompatible with those thinkpads - you can boot but to a blank blue screen - no tracker or deskbar. EDIT: This is not true, at least for 512mb physical RAM. Read below.

It’s a shame, really. They are great little machines. Their bigger brothers will run beos - I have it permanently installed on a T42 - with Ethernet, graphics, audio and optical drive support - and it will boot and use both cores on a T60 if you turn off dma for ide, and bios calls. I haven’t spent the time to try various Ethernet, graphics, and audio drivers.

I wish it worked on the little X series guys though. The good news is that haiku 32 bit seems pretty happy on the X60, and the WiFi works.

3 Likes

Did you try using an external PS/2 keyboard/mouse?

X60 has no kbd/mouse ports, even using the dock. I tried with USB, no go. I’m trying Dano as I write this.

Okay, here’s some news. On my X60 I did the following:

Set SATA mode to compatible in BIOS
Reduced to 512MB real physical RAM
In the beos boot options menu:
Set fail-safe video mode to 1024x768x8
Check use fail-safe video mode
Check Don’t call the bios

I’m able to boot and use the kbd & mouse. I thought I tried this combo the other day - either I didn’t, or I pulled the plug too fast when I saw the blank blue screen.

So 512MB can and will work. Not sure about the Ram limiting boot loader option with various amounts of real Ram - it might work for you.

I’ll spend the rest of the day trying to get audio, Ethernet, graphics optimized but I’m a little doubtful about video and very doubtful about audio.
image

6 Likes

how did you record it on cd? was using .ISO or .CUE? I would like to test the v3.1 version but I don’t know how to record

I always use bin+cue whenever possible.

1 Like

so i’ll try it this way, thanks.