Beos max, ibm x31 and no lan


#1

hi there.

i’ve searched for hours, but could not find any solutions (or many sites or drivers are offline in 2016).
booted after a long pause the beos max-partition on my lovely thinkpad x31 and everything is fine.
but unfortunately ethernet is’nt working anymore (and i can remember it was working perfectly on this machine).
the two drivers in the network-preferences were rejected with the typical error, after saving and restarting the services.
any idea? its the standard intel pro/100 and lan is working perfectly with haiku …

thank you!


#2

Ethernet worked before with the same BeOS Max version? Is it a fresh BeOS Max install? Maybe a corrupted ISO. Not sure if it helps, but one person reported a conflict between the IDE controller and PCMCIA bridge on his Thinkpad X31 using BeOS Max and PhOS: https://web.archive.org/web/20071111010728/http://laptop.hug-nordic.org/old/laptops_view.php?hid=150


#3

Also, try disabling anything in the BIOS that’s not being used… floppy, PCMCIA, etc.

Try other BeOS versions. Here’s a link to the BeOS Developer’s Edition 1.1: https://winworldpc.com/download/41115A73-18DA-11E4-99E5-7054D21A8599

I tried it out on my old P3 and it works great; I think I like it better than the BeOS 5.03 Pro and Max editions. Maybe it’ll work on your X31 with no ethernet issues.


#4

thank you for your ideas – i’ve tested both: disabling all other ports doesn’t change anything and the developer edition comes without live-option. (i fear a lot of other problems after install, for example the display comes in greyscale/vesa …)
unfortunately my bios is very simple, so the typical “plug&play”-option is missing (it seems to be helpful for some other users with the same problem).
many times i found the mention of this patch “http://www.bebits.com/app/2142”, but bebits disallowed archive.org crawling and i can’t find any copy in the net – anyone got a copy (or the filename of this patch)?


#5

There’s a Terminal command to allow a live session in the Developer’s Edition, but I forget now what it is… looking now. Meanwhile, have you tried Pulkomandy’s software archive? The Bebits #2142 led to a BeGroovy link that referenced an eepro driver for BeOS which might work: http://pulkomandy.tk/~beosarchive/index.pl?search=eepro


#6

… cool, thank you! yes, came across pulkomandys site too, but did’nt use the search function(?)
in the meantime i’m downloading the beos 5 pe ware-torrent (6 minutes left and very nervous …)
i think the solution is very close :slight_smile: you helped me a lot.


#7

Can you post the results, in case anyone else runs across the same problem with the X31?

I couldn’t find the keyboard shortcut for entering Terminal from the BeOS Dev. 1.1 Edition, but I think it’s ALT-N or ALT-T. After getting into Terminal, enter:

/system/Tracker &
/system/Deskbar &

That should enable a navigable “live” version. Also, the keyboard layout may be different, so you might need to experiment with different keys to get some of the correct letters/symbols in Terminal.


#8

sorry for my late response, you’re absolutely right. i did’nt »need« the developer-edition – the network-patch i’ve found on pulckomandys site just worked for me (and the max-edition).
perhaps i’m able to test the developer-edition »between the years«, when its getting relaxed. in the moment i’m using a haiku nightly as main partition and beos max for running my favourites like rack747 :slight_smile: