Bebox Not working, need help

Yeah, that sounds possible. Did you update the ROM recently?

There are Boot rom update floppy images kicking around on the internet. I think there might be a floppy image on the BeOS R5 CD image too.

So - it feels like RAM or something. You could try this:

  • remove the RAM
  • remove/disconnect the various daughter cards
  • clean all contacts with isopropyl alcohol or similar
  • if you know electronics, try testing components
  • put it all back together
  • pray to your preferred god figure.

If it is the boot Rom, it is an issue. The Boot Rom is not just a Rom, there are two parts. It has a “nub” and the main updatable image. You’d need to find a way to program a new chip with the nub part at the very least (I don’t think the boot ROM Update disks ever touch that part.)

I have been playing a lot with old Mac hardware recently, and old hardware is tricky. It an look bad, but just have a dirty contact. I thought I killed my 9500 a number of times but stripping it and putting it back together… it is just problematic sometimes.

I don’t own a BeBox anymore, so I’m sorry i can’t help more. You might get info fromt he old Be Newsletters about troubleshooting this type of issue. Also, maybe reach out to someone like Joseph Palmer. Who knows…

1 Like

Hello, no. I got the bebox from a friend, we traded two computers. he told me that the bebox is not working. I’m now trying to fix it.

I found this on a bebox website:

When you turn on the BeBox, CPU 0 starts running in the nub, while CPU 1 is held in reset. The >nub’s job is to locate, size, test, and configure the memory, check the floppy drive for a special Boot >ROM Upgrader disk, and then pass control to the main part of the boot ROM.

I did a dump of the AM29F040. And i ordered a New old Stock over ebay. So i can write a new BootRom, i know It’s partitioned into sections, including a small “nub” and a main part. If someone can provide me a Rom Dump File would be awesome. Otherwise it is very difficult to create a working one.
IMG_8520

2 Likes

The RAM has to be installed by pairs unless, did you only replace one stick?
Is the floppy drive plugged in (correctly)?

Look here for some of the BeDevTalk mailing lists and comp.sys.be archives, one the posters may have had the same problem:
http://lorezan.free.fr/collection/be/BeSpecific/

Edit:
I started browsing through both the newsgroups and mailing list, found that specific problems multiple times:

one person had this issue intermittently, he sometimes managed to boot it by gently pushing on one of the side panels, or turning it off and on again a decent number of times, also sometimes nothing was working anyway.

A few people had problems with some keyboards causing the system not to start up as well.

A thread in May 1996 had someone (the BeOS bible author Chris H.) with the exact same problem as you, both LED ramps being lit up all the time and nothing else happening) being due to the power supply being set to the wrong input voltage by default on its brand new BeBox, Be tech support eventually found out that it would cause the problem after some further testing later in that mailing list thread.

1 Like

Not sure if it helps but the Boot ROMs are here, if someone has a handy C program to dump the ROM in its entirety including the nub I can get it off my BeBox I expect. There is also what looks like the Nub + ROM here as well. If you have the dumps from your programmer it should be possible to confirm if indeed it has a ROM on there from the images linked, typically any recently used BeBox would have R3.2 or 4.5 (or 5?) ROMs loaded, would take a bit of comparing to figure out which ROM it is. Note if it’s an older BeBox it may not support the latest ROMs but looks like it is one of the newer ones.

From memory the R3.2’s (and below) simply used a dd’ed floppy to load and write, the 4.5/5 used an app + image to write the updated ROM from a working BeOS 4.5/5 install as it was a maintenance release ROM effectively. So the BeBox by default will always check the floppy drive with an access on boot to see if there’s a ROM to load from floppy.

Having said that probably best to (carefully) remove all the expansion cards & RAM (and test it elsewhere), and reset the I/O board, the Number 9 Trio64 cards should still work for video (or Matrox Millennium II) as not just any Trio64 would work it seems (my friend had one and it didn’t, fortunately I had the official one and it worked which he’s borrowing). Also keep in mind to reduce board flex as they’re getting fragile.

I don’t recommend randomly removing the caps without confirming with an ESR meter unless you can definitely confirm they’re faulty, it’s probably easier to start targeting the power supply to check it’s outputting the correct voltages/current as it’s easier to test without needing to have it plugged into your BeBox. If the caps have gone bad in the power supply that could be locking the BeBox up, you should be able to smell if they have leaked (or check with ESR meter once discharged).

1 Like

If you scroll to the end of the rom image with a hrx editor, see if the put the date with the be inc copyright in ascii text, it’s really common for firmwarevof that vintage

I have a BeBox (original owner since 1997 or so) which I haven’t fired up in a long time. When I last tried, it wouldn’t boot and no screen. I removed the hard drives, and it gets to the Be startup screen. It seems like I have a power supply issue.

Does anyone know what type of PSU replacement I should get?

Hap

The BeBox should be using a standard 250W+ AT style PSU (it should list the rated Wattage on the PSU itself). However if it’s booting to a startup screen it sounds more like the hard drives are potentially having issues, so you would need to test/check each SCSI device (ie the HDD or CD-ROM drive) keeping in mind the last device requires SCSI termination (which can make testing harder if you don’t have the required termination resistor packs) so typically you test starting with the last device on the SCSI cable chain. If you have a SCSI CD-ROM drive you could use your original boot discs to try and boot from as well as a test.

And consider to buy an SCSI to SD adapter to boot from an SD card.

The BeBox only shows the boot logo if the POST works. Does it go through the RAM check with the drives attached? Does it work with a CD-ROM attached? You drives might have failed.

If you have a BeOS install CD, try booting from it with no drives attached. You should still get as far as the installer, even with no available volumes to install to.

As @extrowerk suggests, try to use a more modern drive replacement. You should be able to use IDE/ATA, and the SD-IDE cards are really cheap (~$5) so it might be worth trying one. Or a CF-IDE also a good option, though CF cards can be expensive. But they both are a lot cheaper than the SD-SCSI adapters, which I’d only suggest if nothing else works and SCSI is the only option.

I think the old hard drive or drives may be tanking the power supply - that happened on my BeBox - an old Connor scsi. With the hd plugged in, dead. Pulling the hd and I booted to Be logo and debugged/experimented from there. Also my machine had a bad floppy drive and the cd rom needed some tlc too. For what it’s worth I ended up using scsi2sd v6 on that machine. Works like a champ.

I may have to look into that. I’ll replace the PSU as well. Do you have a good source for the drive?

I’ve used http://www.inertialcomputing.com/ the last few times I’ve purchased scsi2sd boards. Before that I think I bought them directly from codesrc (McMaster) in Australia but that was years ago…

I purchased direct from CodeSrc here recently, no issues. The other offical source is Inertial Computing. Hapaziz keep in mind there’s knockoff editions floating around around the same price with a shorter board length that are unlicensed, so best to put your money to the official versions.

(From memory SCSI2SD supports CD-ROM more formally vs BlueSCSI so this seems a better bet for loading existing CD-ROM media as most of the SCSI CD-ROM drives no longer tolerate burnt media. Really need to sit down to try loading up the older DR, PR and R# releases of BeOS on my BeBox).

What is the main difference between the 6 and the 5.2? I can see the UK reseller is selling the 5.2, but not the 6. The UK price is about the same an Inertial Computing has their 5.2, but then it will ship directly to me rather than from over seas (and I will not get stung by import tax.)

I really want one of these for my PowerMac 9500, and the drives it has a old and will probably fail soon. My big ~30GiB SCA one is already very problematic and sometimes takes a few attempts to boot from.

The 6.0 gives true SCSI II speeds. Made a huge difference in performance on my BeBox. Not sure about the 9500, whether it would make a difference, but on the BeBox a 5.x felt “broken” if you know what I mean. I used it okay until the 6.0 arrived but it was not the performance I expected or have gotten from any vintage macs using scsi2sd. There are some other 6.0 features like being able to see the file systems via usb on a modern computer but for me, popping the card and reading directly is easy enough and WAAY faster.

The 9500 has probably got similar speeds SCSI. It also has 2 SCSI busses. I think it would be worth getting the 6.0 version, so I’ll look at that. I also want to add more RAM.

My UMAX C500 is mainly missing the L2 Cache, so it needs less work.

I think the umax c500 uses the same cache slot as Spartacus. If that’s the case I have an extra…

Wow, that would be amazing. I believe it is also the same as the PowerMac 5x00/6x00 (well the ones with 603 processors.) The architecture is Tsunami. PM me and we can talk about cost/shipping etc.

edirol-dv-7dl-internal

This is epox 4pda 3pro? :slight_smile: :slightly_smiling_face:
If this true, this company read my things :)), i buyed in this time too this motherboard

No, it’s a DFI GIC68-D.