Battery Status Indicator

I accidentally deleted the PowerStatus applet out of my tray and when I click it again it will not go back. Instaed, it puts a widget on my desktop. How can I get the applet back into my tray instead of on the desktop?

I can’t reproduce what you’re seeing with a current nightly build over here, so it may have been fixed already. When I open PowerStatus, I’m asked to either install into Deskbar’s tray or “Don’t”, which opens a window with a replicable battery symbol. It never get’s installed to the desktop by itself…


The Power Status app wont show up in my Deskbar either. I clicked “install to deskbar” but it dosnt do it. Runnning Haiku off of a USB flashdrive. A PNY “Attache” 1GB. Would like to use something other than VESA for this though. Graphics adaptor:Intel Mobile 945 GM/GMS 943/940 GML Express Integrated. Device ID 0x27a2

I still can’t reproduce that. Again, maybe it has been fixed already - I don’t know what revision you’re running. If it’s a nightly build, consider filing a ticket. Running PowerStatus in window mode works? It does need working ACPI (/dev/power/acpi_battery/0)…
Device ID 0x27a2 should be supported by the driver. You are sure you’re using VESA? OTOH, seeing all those tickets, many people seem to have trouble with intel extreme…


If i let it boot without setting vesa mode with spacebar and options the display is of the desktop with many vertical lines moving around. Other odd thing: pineapple news installed to /boot/home wont show folders in the main window or allow data to be written to its folders.The exact error is "couldnt send storage directory to the trash’ Path:/boot/home/PineappleData/news/Servers Problem:couldnt open file"
I just stalled CL-Amp and its working ok. The usual sound only through laptop speakers not headphones thing is a drag, but its something to work on.

OK, then it looks like your intel extreme suffers with the same issues as a few others who reported on the bugtracker. You could remove the intel extreme driver from your system (query for intel_extreme) to avoid having to enter boot option every time (BTW, hold the shift key may be more convenient).
Pineapple seems to have the Trash hardcoded. Haiku has moved if from the Desktop folder to the root directories of all volumes. There’s a comment claiming it’s working on a current Haiku release…


Interesting. Still getting an error message in pineapple news. Since no folders exist automatically in the leftmost pane I tried to create one. Error: Couldnt write folder attribute data. Path:/boot/home/PineappleData/saved/Drafts
Problem: Couldnt open file.
This version of Haiku is R1/alpha2 (rev 36447) GCC 2 Hybrid maybe its too old of version?
Couple of other things I tried that dont work: BeOS Mice newsreader. And the “network status” demo app that lives in the deskbar. It shows as being not connected despite actually being connected to the net. Oh well.

I don’t know guys, but a few days ago it just randomly came bacl. I’m not sure how that happened, but thanks to all.

Its certainly full of suprises. Yesterday it crashed spectacularly when I had WebPositive and Thunderbird open at the same time. The screen went white and then when I moved the mouse around it was “painting” that area of the screen back. Had to lay on the power button to get out of it. Managed to close both apps but Deskbar was unresponsive. Good Times :slight_smile:
Update: got a Logitech M305 wireless mouse and that causes the system to hang at boot.First time I plugged it in it worked. Now, not working. Sticking with the touchpad instead. Updated to OpenSound with the package manager. But OpenSound isnt outputting stereo sound to the headphone jack. I can get sound in the left channel if I plug it in all the way but it mutes the right channel. So I have to plug it in halfway to get both channels to work. Oh well, at least its something.