Atheros AR2413 wifi problem

I’ve tried Haiku R1/alpha3 Revision 42211 on my Acer Aspire 5100 laptop.
First problem: I’ve used the fail-safe video mode because I could only see a black screen after the Haiku logo screen. My laptop has a Ati Radeon Xpress video card. I suppose it is not supported.
Second problem: the Atheros AR2413 wifi card doesn’t work right.

If I run listdev —> device Network Controller
vendor 168c: Atheros Communications Inc
device 001a: AR2413 802.11bg NIC

If I run ifconfig -a —> /dev/net/atheroswifi/0

Now ifconfig /dev/net/atheroswifi/0 list ----> webstar1 (my wifi name)

Then ifconfig /dev/net/atheroswifi/0 join webstar1 [my wifi password] —> No message from terminal.
Next step I run Network program and select my wifi name, DHCP and "Aplicar"
If I run the NetWordStatus applet I can see a circle in the left but it turns to an orange triangle 10-15 seconds later. If I run the browser, I can’t load any page.

You can see all in this screen capture:

Could someone help me, please?

Hi, deejam.

OK, I’ll try the nightly build.
One question: My wifi is WEP encryption, not WPA. Should I install wpa_supplicant?

Thank you.

Wifi is known to be broken in alpha 3. You should download the latest nightly build which has support for the new wpa_supplicant (must be installed thru installoptionalpackage via Terminal).

Also read

It should work, but I haven’t tested. See