Aspect Ratio


#1

How do I change the default in MediaPlayer to 4:3?

Thanks.


#2

AFAIK there is no default aspect ratio in MediaPlayer. It should change according to the played back video file. If that ratio is wrong, it’s either an incorrectly authored video file or a bug in how MediaPlayer determined it (I suppose through the ffmpeg backend?).
Example files for the latter should be filed with a ticket at the bugtracker.


#3

Thank you.
It’s been like that through several iterations of Haiku. All videos play in 16:9. Is it because I have to use Vesa on that laptop?


#4

The graphics driver should make no difference.
Video|Aspect ratio|Stream settings should be automatically activated whenever a video is opened. Does yours have the tick at “4:3”? That would be weird…

In HaikuDepot you find “mediainfo” that you can use to see details of your files.


#5

No tick beside 4:3. And I do believe Stream settings are activated when I open each video. But the ratio that streaming provides is too high. Because of what you’ve said, I’m thinking that it’s because I have Screen Resolution set at 1280 x 1024.


#6

Screen resolution is not related to this. Unless your screen resolution does not match the aspect ratio of your display, but in this case, the problem is not just MediaPlayer, everything will look distorted. Is that the case?


#7

If that’s the case, and if you have an nvidia card, you can now add this line to your ~/config/settings/kernel/drivers/vesa to disable the ugly scaling:

nvidia_scaling 1