Anyone Using A Thinkpad Hardware Dock?

I currently run Haiku on and off on a Thinkpad T480s. Hardware is generally well supported. Im blessed not to even need Vesa mode and am able to WiFi without a dongle.

I’ve been tempted to pickup the “Thinkpad Ultra Docking Station” so I can use it as a desktop system. However, im unsure how well that might work with Haiku? I seem to recall threads where folks have had issues using external monitors on thinkpads.

Would be curious to hear from any folks, if they have a similar configuration.

Hi! Not using one, and I am not sure they would be well supported.

On my side (intel graphic card), external monitor works on HDMI only if I have the laptop lid kept closed as soon as the computer is powered on so EFI only detect one active display (the external one).
Maybe the same kind of “trick” would work with a HW dock.

Personally I would refrain from buying a dock to specifically run it (unless you can accept the risk of it probably not working).

1 Like

I use a Fujitsu dock. Don’t expect miracles with the video outputs: ycu will still get only one display at a time and maybe not all of them. In my case, I can use the displayport output with a dvi adapter, but not the dvi output of the dock.

Previously I had a thinkpad x200 and I never managed to get the video outputs working at all. On this one I have more success, so, maybe someday I can finally do some work on multi-display

Looking at various sources including the Lenovo website, it seems that some models have a DisplayLink chipset which is not supported by Haiku AFAICT.
I use a T480s with a usb-c docking station by Port Connect (it doesn’t seem to be in stock, though) and all the ports work:

  • HDMI
  • audio mini jack (it’s a USB 1 audio device which works with the recently fixed usb audio driver)
  • Ethernet
  • Power delivery
  • USB-A ports

I have not tried the VGA and the Mini DisplayPort.

You will not get the power button available in the Lenovo dock but it will not work anyway as it requires a dedicated driver on Windows.

You’d better get one on ebay…


I do not know about Thunderbolt / USB Docks under Haiku. the classic thinkpad docks work, but you ONLY get ONE display, and you have to choose it in the BIOS (First/Main Display Setting)

Well happy to report that external video on the “Thinkpad Ultra Docking Station” does work with Haiku when paired with the T480s, on displayport. As others have indicated you have to boot docked. I have not tried any other ports. The laptop doesn’t seem to support audio out via displayport, but that seems like a limitation of the laptop and not Haiku; as displayport isn’t picked up as an audio device in linux either.

Good news! What about other ports?

I was just testing via USB boot. Will reinstall it on a spare partition and do some more thorough testing later this weekend. Though I am a bit unprepared to test some of them. (No VGA monitor at the momment, and no adapter handy.)

That being said USB replication was clearly working as well. I had mouse/keyboard going.

The docking station is interesting because the keyboard on my T450s is getting worse and the trackpad was awful from the beginning, so it could be moving towards non-laptop future.

But … tell me more about this T480s, with the well supported hardware? Does that mean that trackpad isn’t erratic and oversensitive? I’m not sure what the problem is with mine, it doesn’t always happen, but I suppose it detects my hands through the air. Then the cursor flies off to somewhere. It’s bad enough that for a while I had cardboard or something taped over the trackpad. All I really need is a laptop I can type on and use the trackpad to move the cursor around when I want to.

Alright more testing. (Assuming one was docked at boot). For the record again, this is a T480s with an embedded intel GPU. (Not the NVidia GPU model). In conjunction with the “Thinkpad Ultra Docking Station”. Lenovo part number 40AJ0135US.

  • Video out works for displayport. Not well equipped to test VGA or HDMI this second.
    • Displayport does not carry audio out for me. This appears to be a limitation of the laptop’s intel chipset though and not a Haiku specific failure. Behavior in linux in that regard is identical.
  • USB port replication works
  • Ethernet works
  • Dock’s audio out does not work, but headphone jack on the laptop and it’s internal speakers continue to work fine while docked. Headphone jack port on the laptop is not blocked by the dock.
    • The manual seems to indicate the audio is done via a USB interface. But that isn’t picked up by Haiku’s nightly USB audio driver, even after restarting mediakit a few times.
1 Like

I mostly use the red track point nub. But Ive not noticed anything erratic with the trackpad on the device. It’s presented to Haiku as vanilla PS2 device and not a i2u device. There is however no palm rejection, so it is possible to accidentally move the mouse while typing. But I have never experienced anything as bad as you have described.

Ive honestly had worse experiences with other laptops on more mainstream operating systems. This trackpad performs as I would expect in Haiku.

1 Like

I could be wrong about this, but swore I read that was just a known issue with WiFi right now? Am I wrong? Does auto connect work reliably with other chipsets?

Since I have a realtek USB wifi at hand, I tried booting with that in place, and no wifi action unless I turn it on - same as the idual in my T450s. If that’s what “auto connect” means. Also tested while I was at it - idual performance is at least 60% better (though about a tenth of what I get on the Mac.)

At first I was surprised because mine connects on boot, but of course that’s because I have a shell script that starts it up on boot. “wifi” command, called from a script in config/boot/launch/


case $2 in
'') HOST=MEO ;;
# old modem '') HOST='CenturyLink4362' ;;

case $HOST in

case $1 in
scan)  ifconfig $DEV scan ;;
join)   ifconfig $DEV join "$HOST" "$PW" ;;
leave) ifconfig $DEV leave "$HOST" ;;
*)        echo 'Usage scan|leave|join [network password]' >&2 ;;

It‘s a know issue (with ticket) but it doesn‘t appear for everyone.