Any way to bypass "fatal exception "NMI Interrupt" occured! Error code: 0x0"?

First off I want to congratulate everyone who has worked on Haiku to this point. I have been playing around with Alpha 1 for about a week now and enjoying it.

Now onto my problem… :slight_smile:

OK, so when I boot I get a kernel panic then “fatal exception “NMI Interrupt” occurred! Error code: 0x0”. I can bypass this easily enough by just typing “exit” at the prompt and everything boots as normal. The thing is I would like to get this to not occur at all. I’m wanting to set this up my BeOS machine as a headless box that I can VNC into (yes, VNC works…). If I should ever need to reboot the box this of course becomes an issue.

What I’m looking for is any kind of ideas on what fail-safe options might be useful in getting around this, if there is a way I can pass arguments to the kernel when it boots, etc. Any way of getting around it would be helpful.

Oh, I don’t know if this matters but I can tell you that this is being caused by the network card. The issue started only after I installed the card. I have not seen if it was resolved after I removed the card but I think it’s a safe bet that it would be. Of course I kind of need the NIC so I can’t exactly do without it.

Hi burndark,

you should file this as a bug report at Include your listdev output from Terminal and your /boot/var/syslog.

Sorry, I can’t help you with your question directly.


Only way to bypass is either with: 1) safe mode options or 2) remove driver causing the crash.

But you really should search for other similar bugs, found 1 or 2 like yours, and add to them if the same or create new ticket if your problem is somewhat different.

Thank you both. I’ll file a bug report later.