Alpha1 booting from USB but not from hard drive


Haiku works very fine when booted from a USB key.

so i decided to wipeout the disk (erase all partitions) and run the installer to make a hard disk install.

all went fine.

then i used bootman to create the boot manager.

when i reboot i can see the the Haiku boot loader (with the Haiku entry since this is the only OS installed at the moment).
when i hit enter the screen goes black with a blinking cursor, then the blinking cursor disappear and then nothing, the screen stays black… :frowning:

the second problem is that i can’t manage to have the safe mode pressing the spacebar at boot …
(i tried zillions of time , to this it not a timing issue when pressing the spacebar)

if i press the spacebar when booting from the hard disk then i just end up the normal Haiku boot manager.

if i press the spacebar when booting from the USB key then the screen stays black and after several minutes (around 15 minutes) i end up in the safe mode boot screen !

when i go to the select boot volume option , i can only see one volume named “Haiku” , not sure if is it the USB volume or the hard disk one though …

since i can boot from the USB , i checked if there was some logs , but the /Var directory is empty , no syslog file .

then i went to the kernel settings file and disabled SMP , same result.

my hardware is :

Netbook Packard Bell DOT.M (a perfect clone of the Acer 751h)
Atom Poulsbo chipset.
SATA drive


So how can i troubleshoot this further ?

is there any command i could put in the kernel settings file to force the boot in safe mode ?

i don’t have a serial port on the netbook , so no kernel debugging either.

thanks in advance


some news…

if i boot normally from the hard disk and wait around 30 minutes with the black screen i finally see a message : “no boot path found, scan for all partitions…”

any clues ?